
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
WAGO ProServe 4.2 



 

 

 
Overview 
 
Get a general idea of the WAGO ProServe Software: How to use this Online Help, possible 
applications of ProServe and the individual program parts and improvements compared to prior 
versions. 
 
First steps 
 
Here you learn all the basic functions for a quick and easy start. 
 
WAGO Start menu 
 
You can easily access all program parts from the WAGO start menu. Learn more about the 
possibilities. 
 
productLOCATOR 
 
All information about the productLocator, the comprehensive catalog of our products. 
 
smartDESIGNER 
 
With the smartDESIGNER, you design quickly and easily on the screen and you can see it all, thanks 
to the 3D presentation. 
 
General 
 
With ProServe, WAGO offers you a comprehensive service. With the new ProServe software we are 
also putting more emphasis on innovations in the service area. 
 
The new version 4.2 will offer you many helpful tools which will help you in finding WAGO products or 
in configuring almost any product and, furthermore, some extensive import and export functionalities 
are available, and so on and so on and so on...  
 
What would you like to do? 
 
Learn more about how to use the help  
 
Get a general overview of individual modules 
 
Learn more about the new features of this version 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Help 
 

Opening Help  
 
There are two ways in which help can be opened in the ProServe software: 
 

1. By pressing the <F1> function key or  
· By clicking on Help Topics in the "Help" menu  
 

 If you want information concerning a specific function or a menu option, click on the  
 "Help" symbol in the dialog box. 

 
Text marking in Help  
 
All instructions that pertain to a specific menu option will be shown in bold print. The symbol 
"greater than" (>) seperates the menus, submenus and menu options.  
The instruction to select „Print" in the „Data" menu will be shown as Data > Print, for example.    
 
The Index  
 
The Help index gives you the quickest information concerning a specific topic. Simply click on the 
"Index" tab in the left side of the Help window. This tab will give you a list of entries that will 
display the help needed. 

 
Features 

 
WAGO Start menu 
 
This is the interface for complex software solutions. From here, you can: 
 

· Initiate program and data updates  
· Start all WAGO programs 

 
productLocator 
 
This is more than "just" a product catalog. The Product LOCATOR simplifies the selection or search of 
WAGO items. 
 

· Interactive access to over 15,000 items 
· 15 languages integrated on one CD ROM 
· Extensive search engines 
· Data input in item lists and PCB terminal strips can be done with just a mouse click. 

 
smartDesigner 
 
Designing individual projects using WAGO items is particularly easy. 
 

· Designing a project with rail-mounted terminal blocks 
· Designing a project with PCB terminal strips 
· Designing a project with the MULTI CONNECTION SYSTEM 
· Designing a project with WAGO fieldbus components 
· Designing a project with AUTOMATION components 
· Adding accessories 
· Marking 
· Automatic checking of projects 
· Automatic completion of projects 
· Work with your own item numbers 
· Preferred items can be defined and prioritized 



 

 

· Complete print options for production documentation 
· View the project from different angles 
· Data exchange with CAD/CAE 

 
WAGO smartMarking 
 
WAGO marking system - the name alone already stands for the most streamlined terminal block 
marking system. WAGO smart MARKING minimizes the time spent on specialized marking, yet giving 
optimal printing results.  
 

· WYSIWYG marking 
· Shows a representative of the marking  
· Data import from different CAE systems 
· Marking for WSB, Mini WSB, WMB etc. including individualized marking 
· Library containing technical electronic symbols 

 
A smart MARKING manual is also available! 
 
New Features 
 
smartDESIGNER 
 

· Marking is even easier, now also for WMB inline and marker strips  

· The new item table and stock list gives you a better overview 

· More flexibility when designing carrier rails due to a completely new dialog, including screws 
and nuts for the project design 

· Enhanced documentation due to new layouts and the integrated option to create PDF and 
HTML documents 

· Simplified operation: 

· Drag & Drop function for the project tree 
· Search functions for the project tree 

 
ProductLOCATOR 
 

· Questionnaire search 

 
First Steps 
 
The Windows Function Elements 
 
ProServe is based on common Windows standards and is therefore easy to use. Here you can learn 
more about the common function elements of a standard Windows application. 
 
Installing and deleting the ProServe Software 
 
Sometimes, even the best software needs to be re-installed. Learn step by step how to do it. 
 
General 
 
An exemplary project will give you an understanding of the ProServe Software's most important 
elements. 
 
 
 



 

 

Windows function elements 
 
Tool Tips  
 
For a short description of the symbols used in different applications and corresponding functions, 
place the cursor on the the symbol. The WAGO ProServe software will bring a small informational 
window into view.  
 
Program Symbols  
 
Clicking on the program symbol, that is located at the left end of the title bar, will open the window 
menu.  
Double clicking on the symbol will close the program window ending the WAGO ProServe Software. 
Double clicking on the program symbol within the program will close the window and return to the 
WAGO start menu.  
 
Windows' Window Symbols  
 
The standard window symbols from Microsoft Windows is located in the upper right hand corner of the 
title bar. These symbols can change the size of the existing program window.  
 
 

Minimizing The window will shrink as in the symbol. 
Maximizing The window will be set to full screen. 
Restore This will return the window's size to the previously used setting.  
Close The program is closed.  

 
Title Bar  
 
The title bar of the WAGO ProServe Software includes the program symbol and name, name of the 
active project and the standard Windows' window symbols.   
 
Menu Bar  
 
The menu bars lists all title menus for WAGO ProServe Software. Click on a menu title and choose a 
command. Note: If a command is not available - its font color will be grey.  
 
Working with Menus  
 
Menus can be opened using two different methods: 
 

· Using your mouse, click on the menu title in the menu bar, or 
· By pressing <Alt> and the corresponding key that is underlined in the menu.  

 
To activate the indivdual menu commands, the following methods can be used:  
 

· Click on the desired menu command.  
· Press the <Alt> key, the corresponding key of the underlined letter in the menu, and then the 

key that corresponds to the underlined letter of the required command. 
 
Highlight the command using the mouse and press the enter key. 
 
Working with short-cut keys  
 
Often a short-cut key is a quicker alternative to using a mouse, especially activating commands and 
opening menus.   
 
 
  
 



 

 

Installing and deleting the ProServe Software 
 
Installing  
 
The smart DESIGNER,  product LOCATOR and smart MARKING  programs are on the ProServe 
SOFTWARE 4.2 CD. 
 
Remove any version of the software from your computer using the uninstalling program. The new 
WAGO ProServe SOFTWARE 4.2 replaces completely all prior software versions. Data from older 
versions can be imported or opened 
 
Insert the ProServe CD ROM into the CD ROM drive. Setup will start automatically. 
 

 

 
If the Autostart function is disabled on your compu ter, start the setup from the 
CD. 

 
If Internet Explorer version 5.01 or higher is not installed on your computer it is not possible to install 
the ProServe SOFTWARE 4.2. Please install Internet Explorer Version 5.01 or higher first. A current 
version of the Internet Explorer is on the CD in the iexplore directory. 
 
If you choose complete installation, smartDesigner , productLocator and smartMarking will be 
installed locally. This requires approx. 320 MB of free disk space. Even if you are not installing the 
software on your C:\ drive due to shortage of space, make sure that at least 100 MB of free disk space 
is available on the C:\ drive (for temporary swap files). 
 
If you choose custom Installation you can deactivate the smart DESIGNER as well as the data base. If 
the data base has not been installed, the CD must remain in the CD drive since then the data base is 
accessed from here. 
 
Start the ProServe SOFTWARE 4.2 by clicking on the Icon on the desktop. 
 
If you have already installed an older version of the ProServe SOFTWARE, please proceed as follows:  
Insert the CD into the CD ROM drive. Wait for Autostart or choose the setup.exe file directly from the 
CD ROM. Follow the installation instructions (language selection etc.). If you get a message to 
uninstall the old software version via Control Panel - Remove Programs, choose "Start - Control Panel 
– Software".  
Find the WAGO ProServe Software in the list of installed softwares.   
 
Deleting  
 
Select the option "Remove ". The setup of the old version is started. When you get the options 
Repair/Change, Install or Remove, choose "Remove ". Wait for software being removed. 
Note: Existing project data bases are not removed. 
Restart setup.exe from the CD ROM. 
Follow the installations instructions during setup in order to install the new version. 
 
 
General 
 
Welcome to WAGO ProServe! 
 
The purpose of the following sections is to facilitate designing carrier rails using the smartDESIGNER. 
 
Start a new project 
Boreholes / Fixing holes 
Item search 
Libraries 
Project from items 
Marking 



 

 

 
Start a new project 
 
First, create a new project group: From the main menu choose "Project -> Start Project Group". Enter 
a name and click on "OK". A description can be added, if need be. 
 
A project group is a common folder, e.g. for projects of one customer, one switchgear cabinet etc. 
 
The new project group will now show on the left side of the project tree. Click with the right mouse 
button on the project group and select "Insert carrier" from the context menu: 
 

 
 
A new dialog appears, the carrier rail dialog.  
Verify the data in the marked area and enter a name,too: 
 

 



 

 

 
A click on "OK" at the bottom right of the window closes the dialog and shows a graphic of the newly 
designed carrier rail. 
 
Any later changes, for example modifications to the bore hole data, can easily be made by clicking 
with the right mouse button on the carrier rail in the project tree and selecting the menu item "Change": 
 
 

 
 
Please see the next section to learn more about how to design boreholes and fixing holes. If you 
would like to add items to your carrier rail right away, you can skip this section and go to section "Item 
Search". 
 
Boreholes / Fixing holes 
Item Search 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Boreholes / Fixing holes 
 
With a regular arrangement:  
 

· Determine type of bore hole 
· Determine distance from the beginning of the rail 
· Possibly determine distance from the end of the rail 
· Click on "Set“ 

 

 
 
 
With an individual arrangement: 
 

· Click on "Set“ below the borehole list 
· Position specification can be set individually 
 
 



 

 

 
 

With slotted carrier rails: 
 

· Enter the center for the first borehole 
 

 



 

 

 
Item Search 
 
Items can be searched in the smartDESIGNER as well as in the productLOCATOR. 
 
The following describes the search options in the smartDESIGNER.  
 
A comprehensive documentation of the possibilities offered by the productLOCATORS can be found in 
the section: productLocator 
 
Item number search 
 

 
 
 
When you enter a complete item number you can directly transfer the item to the project, to a library or 
even to a item list. 
 
When you enter only a part of an item number you can start the productLOCATOR by clicking on 
"Search" which will show you relevant items. 
 
Questionnaire search  
 
The questionnaire search allows to search for items by product groups or technical data: 
 

 
 



 

 

Please note the marked line. After every parameter change the search will be narrowed immediately. 
A click on the "Search" button will start the productLOCATOR which will show you a list with all 
matching parts: 
 

 
Table of contents  
 
The table of contents allows to find items by clicking through the captions. When you click on one 
series, the items are listed in the lower part of the window. You can easily drag and drop them from 
here onto the carrier rail. 
 

 
 
When you move the mouse over an item you will get a "Quickinfo" showing all important data. If you 
would like to have more information, click with the right mouse button on an item: 
 



 

 

 
 
Start the productLOCATOR via the context menu in order to see all the details of an item. 
 
 
Libraries 
 
Libraries allow to combine items that are needed often for faster access. 
 
Two libraries already exist when you start the program for the first time: 
 

 
 
The library "Chapter" shows you elements of the product series that is currently selected in the table of 
contents. 
 
A new library can be set up using different methods that are specified in the section Libraries. The 
easiest one to start with is to click on the tab "Chapter" with the right mouse button and to choose 
"New" in the context menu which appears: 
 



 

 

 
 
A new library will appear as "<unnamed>", which can now be renamed. That way it is of course 
possible to set up more libraries for different applications. 
 
There are several methods to fill your user libraries, for example from the smartDESIGNER or 
productLOCATOR product search or simply via Drag&Drop from the table of contents. 
 
Transferring items to a carrier rail 
 
There are several possibilities to transfer items to a carrier rail. 
 
If you are familiar with the WAGO product range, you can transfer items very quickly via the item 
number search. 
 
Simply enter the complete item number and click on "Add": 
 

 
 
If you want to transfer more items then simply increase the number next to the button. 
 
Another easy and intuitive option is to Drag&Drop the items. You can drag and drop the items from a 
library or from the table of contents onto the rail. 
 
You have also the option to insert several items at the same time by pressing the shift key while 
dragging, the following dialog will appear when dropping: 
 

 
 
There are even more ways to transfer items, for more details please consult section smartDesigner. 
 



 

 

Marking of terminal blocks  
 
One of the great advantages of the ProServe Software, apart from offering an easy way to design 
projects, is the standardized marking. In order to mark terminal blocks please proceed as follows: 
 
Select the surfaces to be marked. Simply click on the surfaces of the terminal blocks. If you hold the 
STRG (CTRL) key you can select several surfaces at the same time. 
 

Click on the button Marking:   
 
You can now choose the appropriate marking system from the dialog: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 

 

After having selected and after confirming by clicking "OK" the marking table will appear: 
 

 
 

 
Depending on the number of surfaces you selected, the number of columns in the table can vary. You 
can now work with this table as if you were working with a normal spreadsheet program. Clicking "OK" 
will close the dialog and the new markings appear in the graphical representation of the carrier rail. 
 
The quick introduction is now completed. You have seen some basic functions of the 
smartDESIGNER and should invest a little time to work with the software. 
You can find further information in the section "smartDESIGNER". 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

WAGO start menu 
 
You can start the individual programs by simply clicking on the icon. 
 

 
 
Program / data update 
 
The update function can be used to regularly update data or to update the ProServe programs. 
Choose from the WAGO start menu Internet > Program update or incremental or complete data 
update. 
The data is available on our website under http://www.wago.com 
Languages 
 
Each module has the option to interact in 15 different languages. 
 
The choices available are: 
 
German Czech Finnish 
English (US) Dutch Japanese 
English (UK) Italian Russian 
French Polish Chinese 
Spanish Danish  
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Do the following to choose: 
Choose the menu item Options > Language. 
 
You can change the language in every module separately. 
 
Select the desired language. 
Click on OK. 
 

 
 
 

 

NOTE: 
Your system must be able to support the language. F or example, a Western 
European operating system cannot support the Japane se language.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

WAGO 
 
You can always find the latest news or the location of your local contact person under the menu item 
WAGO. 
 
If you should have any further questions, please do not hesitate to contact our support personnel. 
 
Tel.: +49-(0)571-887-630 
E-Mail: support.proserve@wago.com 
 
productLocator 
 
The product LOCATOR is more than just a product catalog. It allows searches by part number, by 
keywords, by technical specifications of products or you can simply use the table of contents to get a 
general overview of all WAGO products.  
  
Specific products can be sent to an item list and be prepared for export, or it can be sent to the WAGO 
smart DESIGNER. At this point you can design custom rail assemblies or terminal strips or a 
connector from the MULTI CONNECTION SYSTEM can be viewed from all angles. Furthermore, you 
are provided with extensive documentation of your custom rail assembly. 
 
It is always possible to return to the product LOCATOR to look up technical data or to find 
accessories. 
Program start 
 
The product LOCATOR can be directly opened from the WAGO start menu.  
In the WAGO start menu just click on the product Locator button. 
 

 
 
You can also start the product Locator in the smart DESIGNER by clicking the button: 
 

  
 

  
 
or via the right mouse button context menu  
Item number search 
 
There are three different ways to search by item numbers: 
 

using the tab "Item number search/Keyword search“  
using the button "Item number search/Keyword search“  or 
using the menu option View > Item number search / Keyword search  

 
If you only want to search by item number, choose Item Number  from the options. This criteria is 
saved and will be used automatically  for the next search engine for any part numbers/keywords.  
 

 

Both options to search by part number and keyword, can be done 
simultaneously. However, the search engines are fas ter when only one of the 
options is used.  

 
 
 
 



 

 

Entering item numbers 
 
It is possible to search using either the WAGO item number or using your own item number. If you 
chose to search by item number, enter the complete number in the upper field and click on the Search 
button (example: 280-833 or 231-603/019-000). 
 
The rest of the fields in the window will be automatically filled and the technical data along with the 
product picture will be visible for the product you selected. 
 
At this point, a portion of the part number can also be entered. 
 

 
 
The results of the search engine will be a list of all item numbers that start with the same string. 
 

 
 
Double clicking on a particular item will give more information pertaining to that item. 
 

 

 
If there is no result to the search, check if the o ption Item Number Search has 
been activated.  

 
 
 
 
 
 
 
 
 
 
 
 



 

 

Keyword search 
 
There are three different ways to search by keywords: 
 
using the tab "Item number search/Keyword search“ 

using the button "Item number search/Keyword search“   
or using the menu option View > Item number search / Keyword search  
 
If you only want to search by keyword, choose Keyword  from the options. This criteria is saved and 
will be used automatically  for the next search engine for any part numbers/keywords.  
 

 

Both options to search by part number and keyword, can be done 
simultaneously. However, the search engines are fas ter when only one of the 
options is used.  

 
Common words can be entered into the keyword search. Either a complete or partial word can be 
entered. 
 

 
 
 
 
 
 
 
 
The search result will be list of all items containing the word or portion of the word. The list is assigned 
to the product groups. 
 

 
 
Double clicking on an entry in the list will give additional information on the item. 
 

 

 
If there is no result to the search, check if the o ption Keyword Search has 
been activated.  

 
 
 
 
 
 



 

 

Table of contents 
 
There are three different ways to find the "Table of contents“: 
 
Using the tab "Table of contents“ 

Using the button "Table of contents“   
or using the menu option View > Table of contents   
 
As in the Windows Explorer, you can open every single chapter by double clicking on it which will 
allow the whole product spectrum to be seen and further searching can be done.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Questionnaire search 
 
There are three different ways to find the "Questionnaire search“: 
 
Using the tab "Questionnaire search“ 
Using the button "Questionnaire search“   
or using the menu option View > Questionnaire search   
 
 
The new intelligent questionnaire search in the productLocator and in the SmartDesigner offers 
convenient search options while taking into account the technical properties of the selected product 
group.  
 

 
 
The questionnaire search is configured in such a way that there will be no result without a hit. 
Depending on which product group and which detail has been selected, a list with possible technical 
features as well as their values and units will appear. In the columns of the table you can enter the 
values, the limiting values or values within in a certain range. 
The other values are updated automatically. 
In the lower part of the window you can see the number of items found. Clicking on the "Search“ 
button will open a list with all items found. Double click on an item to see all technical data as well as 
approvals and accessories as you are used to.  
In addition, you have the possibility to individually adapt the search properties or search criteria via the 
menu option Settings > Questionnaire search for every product group, i.e. the questionnaire search 
allows customized configuration. 
 
Questionnaire search settings 
 
 
Select a product group. You can select or deselect a technical feature, for example cross section or 
rated current.  The questionnaire search will then only show the features or technical properties that 
you have selected.  
It is furthermore possible to define for every technical feature if you would like to search for a range of 
values which is greater than, smaller than or equal to the specified value.  



 

 

Product groups 
 
The search result from a keyword search will be shown in a list of items.  
 
Double clicking on an item will present a list of items that belong to this product group.  
 
Item list 
 
The next part of the window will present a list of items belonging to the selected product group or to 
the caption of the table of contents. 
 

 
 
Within this list, you can again select an item by double clicking on it which will also open the product 
window 
Product window 
 
When an item has been selected by double clicking, the next window will contain more information 
about the item. The information will include technical data, approvals, product pictures, etc.  
 

 
 
A selection of specialized information can be done using the tab at the top edge of the window.  
 



 

 

 
Counterpart search 
 
The WAGO MULTI CONNECTION SYSTEM involves female and male connectors that can be 
plugged together. The ProServe Software has an added feature - a counterpart search. Searching for 
a female connector that will fit a 5-pole male connector with 5 mm pin spacing?  
 
Simply click on the Show Counterpart button. 
 

 
 
A list of all possible counterparts will be shown. Technical data from both articles can be shown.  
 
 
Manual entry of item numbers 
 
The assignment of your item numbers to the WAGO item numbers can be done manually. To start the 
dialog click the your item numbers. 
 

 
 
In the "Edit your item numbers“ window are two columns. In the first column enter the WAGO item 
number and in the second enter your corresponding part number. Confirm the entry by pressing the 
Enter key. You will get to the next row. 
 
 An error will appear if an invalid WAGO number is e ntered. Check that all item 

numbers have been entered correctly including all s pecial characters. 
Otherwise, search for the item with the search func tion.  

 
 
 
Importing your own item numbers 
 
The assignment of your item numbers to the WAGO item numbers can also be done automatically.  
Click on the Import button within the "Your item numbers" window. Choose the path where your 
information is stored. 
 
Your import file must have the following format: 

 
WAGO item number; your item number (semicolon as de limiter)  
 
 An error message will appear if data contains incor rect WAGO numbers or if 

the format was not followed. Check that all part nu mbers have been entered 
correctly including all special characters. Otherwi se, search for the item with 
the search function. Check if the data follows the correct format.  

 
 
 
 
 
 
 
 
 
 
 



 

 

Printing a data sheet from the productLocator 
 
Open the dialog for the print settings via the menu option File > Print. Version 4.2 does not only offer 
the possibility to print but also to save the data sheet as a PDF or HTML document. You can make 
your selection in the Destination area "Export, preview or print“. Elements such as data sheet, 
approvals, accessories, product pictures or product texts may be printed out or ,alternatively, be 
deactivated by clicking on the symbol to the left of the text. Deactivated elements are marked with a 
black cross in the symbol. 

 

 
 
Transferring items (smartDesigner) 

 
Items can be transferred directly from the product LOCATOR to the smart DESIGNER. Before this can 
be done, make sure that a project is opened in the smart DESIGNER and the window with the carrier 
rail is activated. 
 
Direct transfer of an item number: 
 
If during the item number search a specific part number has been found, click on the button Transfer 
to Project. The item will automatically be inserted into the activated project in smart DESIGNER. 
 
Choose from an item list: 
 
If an item list with the specified items is set up in product LOCATOR, individual items can be 
transferred to smart DESIGNER.   
 
This can be done as follows: 
Click on the item in the item list. Click on the Transfer button. 
Or click on the item with the right mouse button and select menu item Edit > Transfer. 
 
The item will be automatically inserted into the activated project in smart DESIGNER. 
 
 
Transfer to a library 
 
Items can be transferred directly  from the product LOCATOR to the smart DESIGNER. Before this 
can be done, make sure that a library is opened in the smart DESIGNER or create a new library and 
activate it. 
 
Direct transfer of item numbers 
 
If during the item number search a specific part number has been found, click on the button Transfer 
to Library.  



 

 

 
The item will automatically be inserted into the activated library in smart DESIGNER. 
 
Choose from an item list 
 
If an item list with the specified items is set up in product LOCATOR, individual items can be 
transferred to a library in smart DESIGNER.  
 
This can be done as follows: 
Click on the item in the item list. Click on the In library button or click on the item with the right mouse 
button and select menu item Edit > Transfer to library.  
 
The item will be automatically inserted into the opened library in smart DESIGNER.  
 
Transfer to CAE systems 
 
Via the button or menu item "Export to Aucotec" you can transfer technical data of an item to 
Engineering Base. 
 
WAGO 
 
In the product LOCATOR you can maintain a list of addresses. Via the menu item WAGO > Addresses 
you have the opportunity to enter new addresses or to change existing ones.  
 

 
 
Here you can also find the latest news or the location of your local contact person 
 
 
 
 
 
 
 
 



 

 

Activate prices 
 
 
Prices can be activated via menu item WAGO >  Activate prices in the product LOCATOR. 
 

 
 
You can get the password from your WAGO contact person. 
 
Settings 
 
You can change the language used in the product LOCATOR via the menu item Settings. As 
mentioned above, 15 languages are available.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

smartDesigner 
 
No time to look through a fat catalogue for a terminal block? Or enter terminal blocks into a 
customized module? Or to compare your item numbers with the manufacturer's number? No need to. 
The WAGO ProServe Software will lead you from a diagram to production, showing each individual 
process. 
A custom rail planned and designed in WAGO ProServe Software can be sent via e-mail. WAGO will 
produce your custom rail with markings. Quick and precise. This will reduce the number of items in 
stock to only one individual item. Furthermore, extensive documentation of the custom rail is available. 
 
Starting a project 
 
A project can be structured by different options, i.e. projects, sub-projects and reference designations.  
  

DIN EN 60204 and VDE 0113 specify that all control cabinets contain a 
comprehensive marking of all equipment.  

A complete identification of electrical equipment is composed of the following parts: 
 
Main identification of the installation 
Location of equipment (where built in or set up) 
Identification of the equipment by type, serial number and function 
Connection markings 
 
Choose Insert Project Group from the Project menu or click on the project window with the right mouse 
button. Choose Insert Project Group from the menu.  
 
Projects can be collected here, for example projects for one customer. 
 

 
 
Give the project group a name and if needed a short description. 
 

 
 
Then individual projects can be added to the group. Again, Project can be selected from the menu or 
by clicking on the corresponding project with the right mouse button. 
 



 

 

 
Analogous to equipment identification, you can Insert drawing, Insert plan, Insert location or Insert rail 
within the projects. 
 
    
 
 If you only work with single terminal strips and an  in-depth structure is not 

needed, the project group can be inserted anywhere on the project tree.  

 
Saving a project 
 
Projects can be saved as follows: 
 
Click on the Save button   
 
Renaming projects 
 
Projects can be renamed after they have been saved. Click on the project name with the right mouse 
button and choose Rename from the menu.  
 
Deleting projects 
 
To delete projects from the project tree, click on the specific project with the right mouse button. 
Choose the menu option Delete.  
 
 

 

 
Please note that all sub-points to the deleted proj ect will also be deleted.  

 
 
Sorting projects 
 

 
 
To sort the project tree, choose menu item Project > Sort project tree or the appropriate 
button.  
 
 
 
 



 

 

Copying projects 
 
To copy projects or project parts such as rails click on an object. You can now copy the object via Edit 
> Copy and edit > Insert or via Ctrl+C and Ctrl+V. The text "Copy of" will precede the copy. 
 
Moving projects 
 
To move a project or a part of a project, click on the object with the left mouse button. Hold mouse 
button and move the object to another position in the project tree. If you want to copy the object, keep 
Shift key pressed while moving the object. 
Searching projects 
 
The search function gives you the opportunity to search for project groups, projects, drawings, plans, 
locations or carrier rails in the project tree of the smart DESIGNERS. 
First, click with the right mouse button on a project group in the project tree. Now select "Serach" in 
the context menu . 
In the field "Searchtext“ you can now enter the name of the project you are looking for, for example, 
and select the branches of the tree where you would like to search, if need be. Confirm your entry by 
clicking on Search .  
You can select a project from the search results and open it directly. 
 

 
 
 
 
 
 
 
 
 
 
 



 

 

Insert rail 
 
If at a specific point of a project Insert Rail is selected, this will bring up a list of available rails. 
 

 
 
At this point you can choose a rail from the list of WAGO standard rails. 
 
The rail must be named. A short description can be given. 
 
  

If connectors from the MULTI CONNECTION SYSTEM or P CB terminal strips 
are in a project, replacement rails can be chosen ( "all mounting options")  

 
You can add information to every carrier rail, e.g. the length of the rail, the position of the first 
component (start position) or the length of the projection.  
 
  

These settings can be changed at any time under Set tings – Carrier rail.  

 
 
 



 

 

Setting holes 
 
If a slotted rail is selected, the type and size of the holes/slots are already set. A selection can be 
made at which position the center of the first hole/slot is in relation to the edge of the rail.  
 
If a solid rail is selected, the type and size of holes/slots can be customized. Bore holes can be set 
automatically at equal intervals (you only specify the first and the last borehole and the number of 
boreholes) or be set individually. 
 
See also 2D Views 
Positioning terminal block on the rail 
 
There are different ways to position terminal blocks on a rail. The positioning can be done exclusively 
in the graphics. In that case, no entries need to be made in the window for the positioning of terminal 
blocks.  
 
If the project must meet certain conditions, these can be determined at this point. For example, you 
can set the position of the first terminal block in relation to the beginning of the rail via the starting 
position. This will make it impossible to set blocks in front of this position.  
 
The end position can also be set to prevent a rail shortage. Then it will not be possible to add terminal 
blocks to the rail over the entered value.  
 
Furthermore, you can determine that your terminal block assembly will always be set in the middle of 
the rail via the "center" button. The start position and the end position will then automatically have the 
same value.  
 
See also 2D Views 
 
Choice box 
 

 
 
The button "Choice box“ gives you the opportunity to get all objects, e.g. all jumper slots, of a terminal 
block or a terminal strip that can be selected in a certain area. This offers the advantage that you do 
not have to mark every single terminal block or jumper slot, all jumper slots can be selected 
automatically in the Choice box mode.  
Click on the "Choice box" button and mark the area of the terminal strip while keeping the left mouse 
button pressed.   
As soon as the left mouse button is released, a window appears which shows you the  different 
connection types. 
Select the appropriate type for which you would like to use the multi selection, e.g. jumper slots, 
operating slots or conductor entry holes.  
Please note that only the areas will be shown that were selected with the Choice box. If you do not 
mark jumper slots while marking the area, they will not be listed. Marking objects using the Choice box 
is a very efficient and fast way of implementing several procedures. 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Free positioning 
 

 
 
If you choose the "Free positioning" mode, you can place components anywhere on the rail.  
 
Press and hold the left mouse button and move the item to the desired position on the rail, release left 
mouse button. 
 
This function also allows to reposition components on the rail. 
 

 

 
If this function is disabled, the items are always inserted after the item that 
was added last.  

 
 
General information 
 
It is not only possible to see the projects in the lists, a graphic layout in different views is also 
available.  
2D views 
 
 
There are several options to view projects. Either use the buttons or click with the right mouse button 
on the appropriate sub-point.  
 
 

 
3D view 

 
In order to use the WAGO item numbers easily in projects, 3-D is available in addition to the 2-D view. 
 

The project can be turned and viewed from all angles. Either choose the  Rotation  button, the 
menu path View  > 3D or click with the right mouse button on the project window and select 3D. 
 
Afterwards, click with the left mouse button on the project window. Holding the left mouse button 
down, use the mouse to move the project in any direction.  
  



 

 

 
 
In addition to the "Rotation" button, the version 4.2 features six more buttons in order to move the rail 
in 3D view. 
 

 
 
You can move the rail by clicking on the buttons X rotation up, X rotation down, Y rotation up, Y 
rotation down, Z rotation up or Z rotation down. 
 
Under Options > Settings > General you can also change the zoom factor and the degree of rotation 
for the individual components.  
 
Zoom 
 

 
 
The project can be made larger and smaller. Either select  
the Zoom button, the menu path View  > Zoom or click with the right mouse button on the project 
window and select Zoom. 
 
Then click on the project window with the left mouse button. Hold the left mouse button down and 
move the mouse up to make the project larger or move it down to make it smaller.  
 
 

 

 
Use the + and - keys of your desktop keyboard to zo om. 

 



 

 

 
You can also use the Zoom in and Zoom out buttons to change the size of the project. 
Clip zoom 
 

 
 
In order to enlarge a specific area use the Clip zoom button. Hold down the left mouse button and 
move over the area that should be made larger.  
Move the point of rotation 
 

 
 
The point where the project rotates, can be moved left or right. Either select the Move rotation point 
button or click on the project window with the right mouse button and select Move rotation point. 
 
Then click on the the project window with the left mouse button. Holding the mouse button down, 
move the mouse to the left to move the rotation point to the left and move the mouse to the right to 
move to the right.  
Moving in all directions  
 
 

 
 
The terminal strip or items in a project can be moved in all directions. Either select the Move button, 
the menu path View  > Move or click on the project window with the right mouse button and select 
Move.  
 
Then click on the the project window with the left mouse button. Holding the mouse button down, 
move the mouse to the left to move the rail to the left or move the mouse to the right to move to the 
right.  
 
Reset 
 

 
 
Select the Reset button to view the base set-up. The project will automatically be set back to default.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

General information 
 
The smart DESIGNER provides several views to choose from. 
 
You can activate or deactivate the views via Settings. The views are: 
 
Project index 
Item tree 
Rail 
Exploded carrier 
Libraries 
Tool bars 
 

 
Project index 
 
The tree structure can be viewed or hidden. 
 
 
Item tree 
 
The item search (product LOCATOR)can be viewed or hidden. 
 
 
Rail 
 
The carrier rail along with the terminal blocks can be viewed or hidden. 
 
 
Einzelne Ebenen darstellen 
 
The top levels can be viewed or hidden. 
 
 
Libraries 
 
The libraries can be viewed or hidden. 
 
 



 

 

Toolbars 
 
The main toolbar, rail toolbar, library toolbar and the status indication can be viewed or hidden. 
 
 
General 
 
The search engine from the product LOCATOR can be used directly from the smart DESIGNER. The 
lower left corner of the smart DESIGNER features the same functions as the product LOCATOR.  
 
Item number search / Keyword search 
 
At the bottom left select the "Keyword search / Item number search" tab. 
 

 
 
A keyword, an item number or a portion of one can be entered to initiate the search. The product 
LOCATOR is opened to identify the the item. 
 
As an alternative, enter an exact item number and transfer it directly to the activated project or 
activated  library by using the Transfer to project button or the Transfer to library button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Table of contents 
 
Select the "Table of contents" tab. The table of contents provides another possibility to transfer items 
to the rail or to the library. 
 

 
 
Items can be found by clicking through the captions. These items can be transferred to either the 
project or library. On the item, press left mouse button and drag the item on the rail or in the activated 
library.  
 
If you want to take a look at a variety of terminal blocks from the bottom caption of the table of 
contents first, you can find the items in the system library "Chapter" (example shows Series 2001 (2.5 
mm²). The items can be transferred from here by pressing the left mouse button and dragging the 
item. 
 

 
 



 

 

 
 
 
 
 
Questionnaire search 
 
The new intelligent questionnaire search in the productLocator and in the SmartDesigner offers 
convenient search options while taking into account the technical properties of the selected product 
group.  
 
The questionnaire search is configured in such a way that there will be no result without a hit. 
Depending on which product group and which detail has been selected, a list with possible technical 
features as well as their values and units will appear. In the columns of the table you can enter the 
values, the limiting values or values within a certain range. The other values are updated 
automatically. 
In the lower part of the window you can see the number of items found. Clicking on the "Search“ 
button will open a list with all items found. Double click on an item to see all technical data as well as 
approvals and accessories as you are used to.  
 
Select a product group. You can select or deselect a technical feature, for example cross section or 
rated current.  The questionnaire search will then only show the features or technical properties that 
you have selected.  
It is furthermore possible to define for every technical feature if you would like to search for a range of 
values which is greater than, smaller than or equal to the specified value.  
 
 

 
 
 
Transferring items from a library 

 



 

 

Items can be transferred directly from a library to a project. Click on the specific item with the left 
mouse button and drag the item to the activated project. Once the mouse button is released, the item 
will be placed in the project.  
 
Items from the library can also be transferred by clicking on the item with the right mouse button and 
selecting Copy from the menu options. Once in the project, select Paste.   
 
Copy and paste is also possible via the Copy button (in the library) and the Paste button (in the 
project). 
 

 

If the shift key is pressed when the item is being dragged over and the left 
mouse button is released first, a small window will  appear with different 
choices. At this point, the amount of items to be i nserted can be entered.  

 
Pluggable electronic modules  
 
The items can accommodate pluggable electronic modules. Proceed as follows: 
 
Select a pluggable electronic module from the product LOCATOR or from a library.  
 
Click on the item with the left mouse button. 
Keep the mouse button pressed and drag the module to the receptacle terminal block. 
Release the mouse button where you would like to place the electronic module. The module is placed 
automatically. 
 
Female connectors for terminal blocks from the MULT I CONNECTION SYSTEM / X-COM-
System  
 
The items can accommodate female connectors. Proceed as follows: 
Select a female connector from the product LOCATOR or from a library.  
 
Click on the item with the left mouse button. Keep the mouse button pressed and drag to a conductor 
entry hole of a base receptacle terminal block. 
Release the mouse button where you would like to place the female connector. The connector is 
placed automatically. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Inserting items at defined positions 
 
In addition to the normal way of transferring items, it is possible to insert items at defined positions. 
Select and mark an item from the library or from the project. A click on the right mouse button will open 
the context menu. Select "Insert article(s) at given position“. As an alternative to the mouse menu, you 
can also use the standard WINDOWS commands to copy and paste items. A window opens in which 
different settings can be made. 
 

 
 
First, define the reference basis which identifies the position of the items. There are three different 
options to choose from:  
 
· Distance from the start of the carrier rail 
· Distance from the left side 
· Distance from the selected or from the last terminal block.  

 
Enter the appropriate value in the field "Distance in mm“. In order to make it easier to insert several 
items after the first one you can enter the number of items in the field "Number of inserted articles“. 
Click on OK to complete the process.  
 
The same functions are available when copying items within a project. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Favorites 
 

 
 
In order not to have to choose from a large variety of end plates, you can define favorites that will be 
automatically used when you transfer the terminal blocks. 
 
To define favorites, proceed as follows:  
Select Edit > Edit favorites or click on the Favorite button  
 

 
 
Enter the item number of the terminal block you want to transfer and click on the "Search" button. 
Mark the item in the list and click on the "Change" button. 
 

 
 
 
Select your preferred end plate. 
 



 

 

User-defined items 
 
User-defined items are "black boxes", i.e. placeholders for non-WAGO products. 
 
In order to create a user-defined item, click on the symbol  or select Edit -> Edit user-defined item. 
 
The following dialog appears: 
 

 
 
Here you have the opportunity to assign your own item number and to specify the dimensions. In the 
event that you have already entered user-defined items at an earlier date, you can select them via the 
Search field or change them, if need be. 
 
Click on OK to add the user-defined item to the "User-defined items" library from where you can now 
transfer the item to your project 
 
 

 

If you get a project with a user-defined item, you can add the item to your 
library via the right mouse button "Save as".  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Deleting items 
 
Within a project existing items can be deleted. Click on the item with the left mouse button. Either 
select Item > Delete items or click on the item with the right mouse button and select the Delete 
option.  
Moving items 
 
Within a project, existing items can be moved on the rail. Click on the item. Keep the mouse button 
pressed and move the item to the desired position on the rail.  
 

 

You can only move an item to any position if the "F ree positioning" 
mode is activated.   

 
  

 
Copying items 
 
Within a project, existing items can be copied and inserted. Click on an item with the left mouse 
button. Click on the Copy button. Click on the Paste button.   
 
This functionality is also available via the right mouse button. Click on the item with the right mouse 
button and select Copy. Now select Paste, again using the right mouse button. 
 

 

When working with the right mouse button, the menu item Insert item several 
times is available. A button with the appropriate f unctionality can also be 
selected.  

 
Turning the terminal block 
 
You can change the open side of the terminal block and turn marked terminal blocks on the rail via the 
"Turn terminal block" button. 
Replacing the terminal block 
 
The new version 4.2 of the ProServe Software offers the possibility to replace terminal blocks on a rail. 
First, select "Replace terminal block" in the context menu or click on the Insert/Replace button. 
Now select a terminal block from the carrier rail which you would like to replace and choose the 
terminal block you would like to insert instead. Keeping the left mouse button pressed, drag the new 
terminal block into the carrier rail window. Release the left mouse button and the smart DESIGNER 
automatically replaces the terminal block. 
As an alternative you can also enter the item number of the new terminal block directly and click on 
the Replace button. 
 
If you click on the Insert/Replace button another time, you disable the replace mode and can proceed 
as usual. 
 
 
 

 

After startup, the smart DESIGNER is in the insert mode. If you change from 
the insert mode to the replace mode you will get a message!  

 
General information 
 
If you mark a component, the appropriate accessories will be available. By clicking the right mouse 
button or via the appropriate buttons you can transfer end plates, protective warning markers etc. to 
your project. 



 

 

 

 
 

 

 
End plates can also be set automatically during che cking (AutoAudit) of the 
complete rail assembly.  

 
Setting end stops 
Setting jumpers 
Setting insulation stops 
Setting protective warning markers 
 
Setting end stops 
 
End stops can be directly positioned on a rail. Click on the last item and select End stop in the 
Accessories menu or the End stop button 
or click on the last item with the right mouse button and select End stop. A window with the 
appropriate end stops will open. 
Setting jumpers 
 
In order to common two or more terminal blocks, click on the jumper slots of the items and select 
Jumper in the Accessories menu or the Jumper button or click on the items with the right mouse 
button and select Jumper. 
 
A window with the appropriate jumpers will open. Double click on the jumper you want to use. 
Setting insulation stops 
 
In order to place an insulation stop on an item, click on the item and select Insulation stop in the 
Accessories menu or the Insulation stop button or click on the items with the right mouse button and 
select Jumpers. 
 
A window with the appropriate insulation stops will open. Double click on the insulation stop you want 
to use. 
 
Setting protective warning markers 
 
In order to place a protective warning marker on an item, click on the item and select Protective 
warning marker in the Accessories menu or the Protective warning marker button or click on the items 
with the right mouse button and select Protective warning marker. 
 
A window with the appropriate protective warning markers will open. Double click on the protective 
warning marker you want to use. 



 

 

 
Marking 
 
Version 4.2 offers new marking functions. Mark one or more surfaces in the terminal strip and click on 
the "Marking" button. You can mark the terminal blocks using the known functions. 
 
If there are no marking favorites available for the selected items, a window pops up where you can 
select the marker type. Confirm your selection by clicking OK.  
 

 
 
A new window pops up where you can enter the values for marking in separate segments, similar to a 
dynamic table. Via "Tab“ you get into the next segment. Via Copy and Paste you can copy the marking 
as you are used to from spreadsheet calculation, for example. 
Automatic marking is also possible via the assistant. This is very convenient and saves time when 
marking long terminal strips. Furthermore, the plausibility check will give a message if there are too 
many characters on the marker tag. 
 

 
 
 
 
 
 



 

 

Marking assistant 
 
If you want to mark several terminal blocks with continuous numbers or characters, using the marking 
assistant is optimal. Select the surfaces to be marked using the left mouse key and holding the SHIFT 
key down. Select the Marking > Marking assistant or click on the button. 
 

 
 
If the surfaces selected can have more than one type of WAGO marker card, a pop-up window will 
appear with the different types of marker options. Select a type.  
 
Click on the appropriate button to open the assistant. 
 
You can then define the composition of the numerical order and character string on the components. 
The assistant identifies the number of marked terminal blocks. 
 

 
 
If several surfaces were selected, an additional option is to reflect the marking from the left side to the 
right side, for example. 
 
To continuously mark all the positions, select the option Continuous marking. The continuous 
markings will proceed to be placed on all the surfaces.  
 
Standard marking 
 
WAGO has defined an optimal font and font size for every marker type, depending on the number of 
characters and lines on the marker tag. You can choose this standard marking for the entire terminal 
strip by clicking on the "Standard font" button. 



 

 

 
 
 
 
General information 
 
During the development of a project, the system continuously checks that the arrangement 
corresponds with the technical conditions. From bore size on a rail to placement of separator plates 
and end stops, the system supports the user and therefore guarantees that all technical conditions are 
being considered.  
 
These checks can be done in different ways: 
 
With Online checking 
With plausibility check 
With AutoAudit 
 
Online checking 
 
The checks are continuous during the development of the project. The online checking is activated in 
the menu Options > Settings under General. 
 
During the project development, smart DESIGNER continuously monitors the construction and makes 
corrections if, for example, an end plate needs to be added because of exposed metal when a larger 
and a smaller terminal block are connected.  
 
In an I/O project a note may be that an additional power supply module needs to be added to provide 
internal current supply.  
This so-called plausibility check assures that the construction of the project is correct.  
 
The program will provide a pop-up window showing parts that can be selected to meet the 
requirements. Selections can be made by simply double clicking on the item in the suggestion list.  
 
Plausibility check 
 
No checks are done during the development of the project. Once the project is finalized, the errors can 
be shown.  
AutoAudit 
 
No checks are done during the development of the project. Once the project is finalized, AutoAudit will 
automatically check the project and provide additional information.  
 
The most efficient method to check a projects, is have automatic checking and correcting all errors 
after the finalization of the project. Select the menu Project > Check project - AutoAudit or click on the 
appropriate button.  
 

 
 
The program will automatically check if everything is plausible. If components must be added, you can 
choose them from the dialog, for example end plates. If favorites were already defined, the end plates 
are added automatically. 



 

 

 
 
 
General information 
 
Should specific products be used continuously or only a limited spectrum of items is used, a 
specialized library will make things more convenient.  
 
The libraries can be found on the right side of the bottom frame in smart DESIGNER. The tab on the 
left side is already defined. The listed items pertain to the caption at the lower end of the Table of 
Contents.  
 

 
 
 
 
 
 
 
 



 

 

Setting up a new library 
 

A new library can be set up using two different methods. 
Select New from the menu Library. 
 

 
 
Click on an already existing library with the right mouse button and select the menu option New.  
 
A new tab will appear as <unnamed> at the bottom right side of the screen. Click on the tab and name 
the library.  
 
The terminal blocks in the library can be shown in different views via the menu option Library or via the 
appropriate buttons.   
 
 

 
Saving a library 
 
There are two ways to save libraries. 
Click on the library with the left mouse button. Select Save from the Library menu.  
 

 
 
Click on the library with the right mouse button and select the menu option Save. 
 
 



 

 

Renaming a library 
 
An existing library can be renamed.  
Click on the library that should be renamed with the left mouse button. Select menu option Rename 
from the Library menu.  
 
Or click on the library with the right mouse button. Select Rename from the menu options.  
 

 

 
The standard library " Chapter“ cannot be renamed.  

 
 

 
 
Deleting a library 
 
When a library is no longer needed, it can be deleted from the list of libraries.  
Click on the library with the left mouse button. Select the menu item Delete from the Library menu.  
 
Or click on the library with the right mouse button. Select Delete from the menu options.  
 

 

Please note that when a library is deleted all the individual connections are 
also deleted.  
The standard library "Chapter" cannot be deleted.  

 
 

 
Transferring an item to the library 

 
There are several different ways to transfer items to a library when a new library has been set up: 
 
From the item number search  
 
If you have entered an unambiguous number, you can directly transfer the item via the Transfer to 
Library button (the library must be activated).  
 
From the table of contents  
 
When one of the captions at the bottom of the table of contents is activated by double clicking on it, a 
list of corresponding items will appear. Click on a specific item with the left mouse button and drag the 
item into the activated library.  
 
From a project  
 
Items can also be transferred directly from a project to a library. Click on a specific item with the left 
mouse button and drag the item to the activated library. Once the mouse button is released, the item 
will be placed into the library.  
 
Items from projects can also be transferred by clicking on the item with the right mouse button and 
selecting Copy from the menu options. Once in the library, select Paste.   
 
Copy and Paste can also be done using the Copy button (in the project) and Paste button (in the 
library).  
Print mode (documentation) 
 
Under menu item Options > Settings you can select Print > Printing mode in the left window. 



 

 

A click on the "Options" button will show which settings can be defined in which data sheet or printout. 
For example, the top view of the terminal strip can include dimensions, the drawing can include user-
defined item numbers. Furthermore, a zoom factor can be added to every page or data sheet which 
makes it possible to zoom in or zoom out individual elements, e.g. top view or side view of the terminal 
strip.  
It is also possible to integrate individual templates. You can name these templates by clicking on the 
"New template“ button. A click on the "Insert template“ button imports the customized template into the 
"New template" folder which has been defined before.  
Goal: define different templates, e.g. for production (graphics) and for purchasing department (parts 
list) 
You can use the button "Set as standard“, to set a specific folder as standard , the other folders are 
disabled.  
In order not to have to print all the data sheets, you can disable individual templates. Click on the 
symbol next to the corresponding term, e.g. top view with empty rail, in order to enable or disable it. 
The symbol at the left side of the term will be marked with a black cross.  
 
Printing 
 
 

 
 
Open the print menu via File > Print or the corresponding button. You can select or deselect the preset 
layouts. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Print preview 
 
 

 
 
The menu item File > Print preview along with the print menu gives you the opportunity to see and 
check the printouts on the screen. 
Saving documents in the HTML / PDF format 
 
All item data as well as terminal strip projects can be saved as HTML or PDF. To save a 
documentation or a data sheet, click on the Export button in the print settings and enter the desired 
path.  
 
Page breaks 
 

 
 
If there is a large section consisting of the same terminal blocks (e.g. 30 x 280-833) on your rail or you 
would like to leave a certain section of the rail empty, you can remove this area via the Set page 
breaks button.  
 

 
 
The Page break info  button allows you to see the number of pages that would be printed using the 
different layouts or the number of pages by which it would be reduced when using page breaks. 
 

 
You can delete the page breaks via the Reset page breaks button. 
 
 



 

 

Batch print 
 
If you would like to print several projects in a row, you can do this via the menu item File > Batch print. 
A window with all project components pops up. By activating the project and, if required, by changing 
the settings you can generate an individual list that can be printed. 
You can save the list and load it again (also at another PC). 
Printing on WMB Inline or marker strips 
 
If you used WMB Inline or marker strips when designing your terminal strip (e.g. topJob S Series ), you 
can directly print these markings via the thermal transfer printer. Please note the options of the output 
devices. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 
Order data 
 
You can open a project data administration dialog under the menu item Project > Project data or by 
clicking on the carrier rail in the explorer window with the right mouse button and selecting Project 
data. 
 

 
 

 
 
The fields Project to Device designation are directly filled by the project tree. The fields Notes can be 
used to add some general information about the project.  
 
The list of addresses is opened via the address buttons. 
 
 
 
 
 
 
 



 

 

Additional data 
 
More data can be added via the "Additional data" button. 
 

 
 
The data that is entered here will be shown on the printout of the terminal strip. The field names for the 
optional texts (Optional 1 to 7) can be changed in the menu Options > Settings. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Options - General 
 
In this dialog you can do the standard design settings. 
 

 
 
Options - Settings - Print 

 
Since documentation requirements are manifold and individual, version 4.1 or later offers new 
convenient setting options that can even be configured freely in many areas. Basically, two different 
fields are differentiated:  
 
the print mode for documentation creation 
the settings for printing marker strips and WMB inline 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Settings for marker strips 
 
Please note that all settings were thoroughly tested by WAGO and that they normally fit perfectly. 
However, should it be necessary to change the settings, for example due to large  temperature 
fluctuations, the changes can be done individually in different ways and with different effects, e.g. 
correction values. Wear and tear on the printer, e.g. the roller, could also be a reason for changing the 
settings.  
Another factor is that some printer drivers will not accept the value entry. 
If you have any questions, please contact us under +49 (0) 571/887-630, our support team will be 
pleased to help. 
 

 
 
 

The individual set parameters and their importance are described in the following: 
 
Distance from left edge 
The print area is approximately the width of the roller. The value "25“ indicates the distance in mm 
from the left edge to the start of the print area. 
 
Text distance from left edge 
Normally, the text is printed exactly as it is defined in the project. It is centered text relating to the width 
of the marker strip. If this reference value shall be changed, the correction value is entered in this field. 
The value is given in mm. 
 
Line width 
Each raster is marked by a dividing line. The line width in mm is entered in this field. 
 
Cut marker width 
In order to ensure a precise marking of the marker strip sections which must be cut due to different 
heights of the terminal blocks on the rail, the appropriate line width can be entered or changed here. 
The value is given in mm. 
 



 

 

Stretch factor 
The stretch factor is used to compensate for terminal block tolerances. 
 
Printer factor 
The printer factor is a device-specific correction factor that needs to be determined and set once for a 
device. Please consult the WAGO printer documentation for this value. 
 
Number of copies 
Indicates the desired number of marker strips to be printed. 
 
Print dividing lines 
In principle, it is advisable to print the dividing lines. If you do not want to print the lines 
uncheck this option.  
 
 
WMB Inline 
 
You can do the settings for the WMB Inline marker tags, which come endlessly from a roll and are an 
innovation from WAGO, in the WMB Inline tab.  
 

 
 
The individual set parameters and their importance are described in the following: 
 

Distance from left edge 
The print area of the roller is approximately the width of the ink ribbon. The value indicates the 
distance in mm from the left edge to the start of the print area. 
 
Text distance from left edge 
Normally, the text is printed exactly as it is defined in the project. It is centered text relating to the width 
of the marker strip. If this reference value shall be changed, the correction value is entered in this field. 
The value is given in mm. 



 

 

 
Number of copies 
Indicates the desired number of marker strips to be printed. 
 
Options - Marking 
 

 
 
Here you can do the settings for terminal strip markings. Due to the activation of the font size check 
only the fonts for the IP 350 plotter are available which can be used to print the terminal strip marking 
directly from the smart DESIGNER. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Options - Rail 
 

 
 
You have the possibility to define a standard rail which is used for the CAE or Excel Import. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Options - Optional texts 
 
Use the optional texts to add specific information which will be shown in the terminal strip printout. 
Enter the field names and add information via the Additional data section of the Order data. 
 
Enter data changes or customer-specific data for example. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Selecting standard marker types 
 

Most users of WAGO products use a defined range of types of markers. These normally depend on 
the products used. In order to make it easier and faster to find them during project designing, the 
smartDesigner offers the possibility to define favorites via the menu "Options > Settings > Favorites“. 
Only selected items will then be shown during the project design phase.  
 

 
 
Select the appropriate types of markers from the list in the upper area, mark them and click on the 
"Insert“ button. The corresponding item number is transferred to the lower list and is now a favorite. 
Using the "Higher“ and "Lower“  buttons you can change the priority of the defined marker types 
according to their list entry, i.e. the higher the entry is in the list, the higher is its priority to be used. 
 
Import projects 
 

 
 
Projects that were exported as XML can be imported into the smart DESIGNER via the menu 
Import/Export > Import project. 
Import from ProServe Version 2.5 / 2.6 
 
 

 
 
You can import and edit your complete rail assemblies that were created with ProServe Software 
Version 2.5 / 2.6  into Version 4.2 via the menu Import/Export > Import a completely mounted rail 
(V2.5). 
 



 

 

MS-Excel import 
 

 
 
The data is created in CAE programs such as E³, Eplan, ELCAD, Ruplan etc. 
The data is transferred into an Excel template (can be found on the installation CD in the  
...\CAE\EXCELIMP directory). 
 

 
 
Import is done via the menu item of the Excel button: 
 

 
 
 
 
 
 
 
 
 



 

 

Data import from E³, Engineering Base, ELCAD and RUPLAN (EVU-
Modul), ECS CAD and WS CAD 
 
For the above-mentioned programs, the import can directly be done via the menu item Import/Export > 
Import from CAE. 
Data import from Eplan 
 

 
 
Data that has been created using Eplan can be imported into the current version and 
be edited. A data export to Eplan will only be possible with Version 5.50 Hotfix 3 or 
5.60. You can find the update file including a detailed description in the download 
area of our website www.wago.com 
 
 
 
Data import from text files (ASCII) 
 

 
 
With the help of an interface description you can import standard text files. 
 

 

 
You can get the interface description for ASCII imp ort from your contact 
person  

 

 

 
The terminal strips that have been imported via MS- EXCEL or ASCII can then 
be checked by AutoAudit or equipped with appropriat e accessories.  

 
 
 
Standard settings for CAE / MS Excel / EPlan import 
 
To ensure a trouble-free import it is essential to assign an end stop (under menu "Edit > Edit 
favorites") to the standard carrier rail which has been saved under Options > Settings. 
 
 

 

 

 
  
 
 
 
 



 

 

Data export to E³, Engineering Base, ELCAD, ECS CAD and WS CAD 
 
Export from the above-mentioned CAE programs can be done directly via the menu Import/Export > 
Export aus CAE. The components that were added in the smart DESIGNER are transferred to the 
CAE system as "nicht platzierte Bauteile". 
Data export to CAD systems 
 
 

 
 
You can export any of your projects as dxf. Select the menu Import/Export > Export as dxf or the 
Export as dxf button. 
 
Determine the path of the dxf file to be saved.  
You can export this file into any program which uses a dxf filter. 
 
The dfx format is interpreted differently by different programs. Please contact us if the dxf file causes 
problems with your program: Email: support.proserve@wago.com 
 
In addition to the dxf format you have the option to export data as dwg, step or igs. You can then 
directly work with the 2D or 3D data from WAGO in your CAD system. 
This export feature must be activated - please consult your contact person in the Sales Department. 
 
 
Send projects to Wago 
 
 

 
 
In order to ensure the fastest and best possible production you can send your projects directly via 
email to WAGO. You will get a list with all your projects designed so far. Select one or more projects 
from the list. Please add a subject, e.g.  your customer number and the name of the project. 
 
Send your projects to smartdesigner@wago.com. We will check your projects and send you an offer 
as quickly as possible. 
Export item list 
 
 

 
 
The menu item Import/Export > Export item list or the corresponding button allows to create an item 
list file which can be imported into the Office applications or into your inventory control system. 
 
Structure of the item list file: Item number; Description; Quantity 
 
The item list file is an ASCII file with the file extension exp. 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Data export (ASCII) 
 
The menu item Import/Export > Export data (ASCII) or the corresponding button allows to access the 
data base and to create data sheets or lists of your carrier rail. 
 

 
 
Export to smartMarking 

 
  
 
The menu item Import/Export > Export to smart MARKING or the corresponding button allows to 
create a file with the marking data of your assembled rail and to export the file into the marking 
software smart MARKING or WAGO Script. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Start plotting with smartMarking 
 
 

 
 
The menu item Import/Export > Start plotting with smart MARKING or the corresponding button allows 
to send the marking data directly to the IP 350 plotter. 
 

 
 
A smrtMarking manual can be downloaded from the download area on our website 
http://www.wago.com. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

General 
 
The item list is a module which makes it a lot easier to administer product or project data. You can 
create item lists in version 4.2 and then 
 

· save them as a PDF file 
· save them as a HTML documentation 
· print them using individual layout templates or 
· send them to a different system environment as an XML file or an CSV file for further editing 

 
Open the item list window via the menu "Item list > Item list". 
After opening, the window is in the foreground all the time which makes it easy to transfer items from 
the productLOCATOR or the smartDESIGNER to a list while working with ProServe.  
 
Simply drag and drop an item from the productLOCATOR or the smartDESIGNER into the item list.  
 
 

 
 
In this window you have the opportunity to create and administer different lists. The lists are created in 
register files. The lists are displayed at the right side of the item table. A check mark to the left of the 
list name indicates that the register is activated. 
Activated registers are shown under the list. You can see the list entries after clicking on the tab. 
If the window is opened you will automatically get the item table pertaining to the current rail project 
you are working on. This ensures fast data export as CSV file to a spreadsheet program. Furthermore, 
most of the CAE programs can import *.csv files and incorporate them as a parts list  into an existing 
project. The same applies if, for example, the rail data shall be transferred to an inventory control 
system. 
 
 
 
 
 
 
 



 

 

Print and settings 
 
The menu item "Print" opens a pop-up window. In this window you can: 
 

· enable a specific template ( if available) for documentation 
· specify whether to print the list or to display it on the screen 
· create a PDF file of the list 
· create a HTML documentation of the list. 

 

 
 
After clicking on the Options button you can do further settings in order to specify what information is 
to be displayed in the list when generated. 
 

 
 
 
 
 
 
 
 



 

 

Export the item list 
 

As mentioned before, the item lists can be converted into XML or CSV quickly and easily. Select the 
menu Print - Export > Export. 
 
Select the desired format in the  "Export filter“ window and click on OK. Now specify the location of the 
file. 
 
If you choose the Aucotec XML format, the items can be transferred from the list directly to the 
Engineering Base library. 
 

 
 


